Fix manifest to support older versions correctly on Windows

Windows was crashing due to loading the wrong DLL. Came up
with a scheme that seems to work and applied it back to
Firefox 24.

Change-Id: I3ef7651e1152d8eb44d4424fbcf5bc94d1e29698
1 file changed