Update missing plugin page for Firefox

Added a link for downloading Firefox 24.
For unsupported browsers, don't link the caption to the
Google group. (There is a link below.)

Change-Id: I468bc94f65f423c59e6b2d1874cba2e340261182
diff --git a/src/main/site/missing-plugin/index.html b/src/main/site/missing-plugin/index.html
index 79954ed..22a8685 100644
--- a/src/main/site/missing-plugin/index.html
+++ b/src/main/site/missing-plugin/index.html
@@ -139,7 +139,8 @@
   },
 
   "firefox-old": {
-    "caption": "Sorry, the GWT Developer Plugin only supports Firefox 3.0 - 26.0 at present",
+    "caption": "Sorry, the GWT Developer Plugin only supports Firefox 3.0 - 26.0.<br>" +
+    " Perhaps download <a href=\"http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/24.3.0esr/\">Firefox 24</a>?",
   },
 
   "opera": {
@@ -277,11 +278,7 @@
 }
 
 function makeButton(descr, plats, url) {
-  var supported = true;
-  if (!url) {
-    url = "https://groups.google.com/group/google-web-toolkit";
-    supported = false;
-  }
+  var supported = !!url;
 
   function anchor(url) {
     var n = document.createElement('a');
@@ -315,14 +312,20 @@
     return n;
   }
 
-  return anchor(url,
+  var button =
     div('button',
       div('buttonText',
         html(descr),
         div('details',
           text(plats))),
       div('buttonIconHolder',
-        div(supported ? 'downloadIcon' : 'unsupportedIcon'))));
+        div(supported ? 'downloadIcon' : 'unsupportedIcon')));
+
+  if (url) {
+    return anchor(url, button);
+  } else {
+    return button;
+  }
 }
 
 function showBest(x) {